Auto transmission slipping on 3rd/5th

Quido3

Idling at the Lights
Premium Member
Location
Finland
First Name
Petri
Drive
Legnum VR4 1996 PFL
Hello,

so I have the problem as in title. Have been looking here and clubvr4 for solutions, but either it’s something not commonly found or I have just skipped the solution.

The story of the transmission and car it self is quite long, so I’ll skip that and try everything from scatch.

And now the problem. When shifting to 3rd the car has a time it seems to almost freely rev and finally engages the gear. Giving it a bit of time and/or letting the gas helps this and makes the change faster and easier. If not letting the gas the shift has a jolt. When shifting to 5th the shift is fine and I can cruise on that gear, but trying to gain speed seem to have quite a bit of slip and revs increase more that the speed. In either shift if I just try accelerate it results in fail safe mode(stuck in 3rd) and a error code corresponding to the gear that was on(if accelerating on third it might decide to change to 4th so the error is from 4th even though that gear is working).

So, any ideas?

Thoughts what I have had after I thought I tried everything usual:
-flywheel? I tried a flywheel test from the workshop manual and got a bit higher revs than should before my brakes gave way.
-Workshop manual(galant 4 speed) seems to direct to overdrive clutch due to error codes having only that common component as solution.
-Transmission pump?
-Solenoids?
-The selector swith on top of the trans?

Anything else that COULD cause this that is not transmission related? A lot would point to the ECU, but currently I have two for 96-97 and both have identical issues so I don’t think it’s that. Been also flushing the trans with Amsoil, though currently I have some other oil with additives. Seems to not have an effect.
 
Top Bottom