ECUFlash Definitions

kc427

Leaving Skid Marks
Lifetime Member
Location
HK
First Name
KC
Drive
VR4
7201 for 7202
To be clear, if I understand correctly, your car comes with a 7201 metal case ECU, right? So, you physically swap into a 7202 plastic case ECU, right? Because you always mentioned your 7201 working, maybe everyone thinks, at lease I was, that you flashed 7202 rom into the 7201 metal case, and of course it is impossible.
 

Legnum in America

Leaving Skid Marks
Premium Member
Location
Chicago
First Name
Mike
Drive
1997 Mitsubishi Legnum VR4 COTY
2022 Subaru Outback Onyx XT
1999 Honda Civic EX
To be clear, if I understand correctly, your car comes with a 7201 metal case ECU, right? So, you physically swap into a 7202 plastic case ECU, right? Because you always mentioned your 7201 working, maybe everyone thinks, at lease I was, that you flashed 7202 rom into the 7201 metal case, and of course it is impossible.
Yes, the car came stock with a 7201ecu. I purchased a 7202ecu from a member on this site. When I install the 7202ecu the car sputters real bad and there's no tachometer. I'm trying to find a working ROM for the 7202ecu. When I put the 7201ecu back in the car runs normal again.
 

Mattalot

Sparkly Oil
Premium Member
Location
Morayfield
First Name
Matt
Drive
2006 Subaru Liberty Spec.B Manual

1998 Mitsubishi Legnum VR4 Auto

1991 Mitsubishi Galant VR4 Manual (Aus Spec)

2021 Daihatsu Copen GR Manual
I don't know a great deal, but from my limited testing it looks like the seperate tables for desired engine load and waste gate are from "Low / High Gear"

I noticed changing the first tables would change the boost pressure of 1st-2nd gear while leaving 4th-5th alone and only changing 3rd the slightest.
Noticable difference though, not just a tiny 1psi.
Was able to change the boost pressure of just lower gears by 8psi without effecting higher gears.

Started testing that theory as the Colt Ralliarts have those tables defined as "low gear" and "high gear"
As i couldn't find any other Mitsubishi that had two seperate tables for engine load and waste gate but the Legnums and the Colts.
How the car works out gears though i'm not sure.

Maybe some form of RPM and Wheel Speed?

But i'm pretty positive that the 1st and 2nd maps for Target Engine Load and Waste Gate is for Low gear and High gear.
 

BCX

Administrator
Moderator
Location
SA
First Name
Bill
Drive
2000 Galant Type-V
1997 MK Triton GLS [6G74 conversion]
2019 i30 N-Line
Interesting. Will have a look at the disassembly and report back
 

BCX

Administrator
Moderator
Location
SA
First Name
Bill
Drive
2000 Galant Type-V
1997 MK Triton GLS [6G74 conversion]
2019 i30 N-Line
With BDEL and WGDC - the 1 & 2 relates to ROM Config.... So an EM2004 would use 2, EM2005 would use 1.

WGDC & BDEL are interpolated between hi & low by use of value stored in MUT 0x27. This is the same as hi/low fuel tables, ign tables.
This location i've called 'octane flag' but really its what % of interpolation between two map values.

As knock count increases, 'octane flag' used to prefer low octane map values.

But there might be something else at play, there is a whole WGDC trim subroutine that does have lot of conditions to it.
 

BCX

Administrator
Moderator
Location
SA
First Name
Bill
Drive
2000 Galant Type-V
1997 MK Triton GLS [6G74 conversion]
2019 i30 N-Line
Yes, the car came stock with a 7201ecu. I purchased a 7202ecu from a member on this site. When I install the 7202ecu the car sputters real bad and there's no tachometer. I'm trying to find a working ROM for the 7202ecu. When I put the 7201ecu back in the car runs normal again.

My only suggestion to you is to try another ROM that's not EM2004/EM2005. Hope to upload a repository of original, unmodified ROMs soon.

You've posted in other sections of the forums asking for definitions. All the definitions for our ECUs are on GitHub. Even if you used definitions that aren't as comprehensive, it wont fix your issue. The ROM contains everything that the ECU needs to run (the program the ECU executes to keep the motor ticking over, and all the values in the tables). All the definitions allow you to do it make sense of the values so you can change them if needed.

In your case, you are trying to put an unmodified ROM onto this ECU, which should just work, regardless of which definitions are in use. so even with incomplete or incorrect definitions, so long as:
  • the ROM you are flashing is unmodified
  • the memmodel is set correctly, so for a 7202 make sure Ecuflash is using H8539F (not FA, see screenshot below)
  • the ROM successfully flashed
Then it should work.

1676549329710.png


Otherwise, sounds like your ECU might be bung. Most people converting to a plastic case ECU just plug-in and play.

I've got a drawer full of different ECUs and all work in my Galant (both 7201 and 7202/03). So something isn't right with your setup.

Tacho signal is generated by the IFS, which sends a pulse each time 1 of the 3 ignition coils fire. So it seems like something isn't right with the way the ECU is driving the coils, or how the ECU is interpreting your crank angle sensor signal.
 

Legnum in America

Leaving Skid Marks
Premium Member
Location
Chicago
First Name
Mike
Drive
1997 Mitsubishi Legnum VR4 COTY
2022 Subaru Outback Onyx XT
1999 Honda Civic EX
My only suggestion to you is to try another ROM that's not EM2004/EM2005. Hope to upload a repository of original, unmodified ROMs soon.

You've posted in other sections of the forums asking for definitions. All the definitions for our ECUs are on GitHub. Even if you used definitions that aren't as comprehensive, it wont fix your issue. The ROM contains everything that the ECU needs to run (the program the ECU executes to keep the motor ticking over, and all the values in the tables). All the definitions allow you to do it make sense of the values so you can change them if needed.

In your case, you are trying to put an unmodified ROM onto this ECU, which should just work, regardless of which definitions are in use. so even with incomplete or incorrect definitions, so long as:
  • the ROM you are flashing is unmodified
  • the memmodel is set correctly, so for a 7202 make sure Ecuflash is using H8539F (not FA, see screenshot below)
  • the ROM successfully flashed
Then it should work.



Otherwise, sounds like your ECU might be bung. Most people converting to a plastic case ECU just plug-in and play.

I've got a drawer full of different ECUs and all work in my Galant (both 7201 and 7202/03). So something isn't right with your setup.

Tacho signal is generated by the IFS, which sends a pulse each time 1 of the 3 ignition coils fire. So it seems like something isn't right with the way the ECU is driving the coils, or how the ECU is interpreting your crank angle sensor signal.
I did try EM2428 but same results, No tach and sputters. The Roms I tried are from ClubVR4 and VR-4.ru

I will double check the settings again. If still not working, I shall wait for the Roms to be uploadedon ozvr4. Also trying to get a hold of Steve from TME but no reply via email. I figure its busier down there since its summer for you.
 
Last edited:

mezje

Leaving Skid Marks
Moderator
Premium Member
Location
Melbourne
First Name
Maxim
Drive
1998 Galant VR4 Manual
I will double check the settings again. If still not working, I shall wait for the Roms to be uploadedon ozvr4. Also trying to get a hold of Steve from TME but no reply via email. I figure its busier down there since its summer for you.

Steve is always busy nowadays, very hard to get a hold of. TME are doing a fair bit of tarmac hill climbs & track work.

I think you should just buy another, untouched ECU. The fact you have a metal case that was tuned for an FTO and have spent so much time trying to fix something everyone says will just work should be enough motivation to start again with a known ECU.
 

Legnum in America

Leaving Skid Marks
Premium Member
Location
Chicago
First Name
Mike
Drive
1997 Mitsubishi Legnum VR4 COTY
2022 Subaru Outback Onyx XT
1999 Honda Civic EX
Steve is always busy nowadays, very hard to get a hold of. TME are doing a fair bit of tarmac hill climbs & track work.

I think you should just buy another, untouched ECU. The fact you have a metal case that was tuned for an FTO and have spent so much time trying to fix something everyone says will just work should be enough motivation to start again with a known ECU.

Slight confusion, the metal case is the 7201ecu that came in the car 7201ecu is stock. I purchased a plastic 7202ecu that was tuned for an FTO, the member was from ozvr4. 7202ecu is the problem child
 

Legnum in America

Leaving Skid Marks
Premium Member
Location
Chicago
First Name
Mike
Drive
1997 Mitsubishi Legnum VR4 COTY
2022 Subaru Outback Onyx XT
1999 Honda Civic EX

Legnum in America

Leaving Skid Marks
Premium Member
Location
Chicago
First Name
Mike
Drive
1997 Mitsubishi Legnum VR4 COTY
2022 Subaru Outback Onyx XT
1999 Honda Civic EX
My only suggestion to you is to try another ROM that's not EM2004/EM2005. Hope to upload a repository of original, unmodified ROMs soon.

You've posted in other sections of the forums asking for definitions. All the definitions for our ECUs are on GitHub. Even if you used definitions that aren't as comprehensive, it wont fix your issue. The ROM contains everything that the ECU needs to run (the program the ECU executes to keep the motor ticking over, and all the values in the tables). All the definitions allow you to do it make sense of the values so you can change them if needed.

In your case, you are trying to put an unmodified ROM onto this ECU, which should just work, regardless of which definitions are in use. so even with incomplete or incorrect definitions, so long as:
  • the ROM you are flashing is unmodified
  • the memmodel is set correctly, so for a 7202 make sure Ecuflash is using H8539F (not FA, see screenshot below)
  • the ROM successfully flashed
Then it should work.



Otherwise, sounds like your ECU might be bung. Most people converting to a plastic case ECU just plug-in and play.

I've got a drawer full of different ECUs and all work in my Galant (both 7201 and 7202/03). So something isn't right with your setup.

Tacho signal is generated by the IFS, which sends a pulse each time 1 of the 3 ignition coils fire. So it seems like something isn't right with the way the ECU is driving the coils, or how the ECU is interpreting your crank angle sensor signal.
All looks ok, maybe its just a bad rom.


Capture.PNG
 

Steve Avery

Idling at the Lights
Premium Member
Location
Nz
First Name
Steve
Drive
Legnum VR4
Hi Bill, it seems the files for the read templates are empty in the github repo.
I'm looking to use Kenneths EMKS11 in your repo (mainly for extended load tables), I notice that this one is now <include>20030013<include> however when I load the rom it defaults to the 20030013 xml. Is there a way to change it to use the EMKS11 when opening a file?
Appreciate your help!

Steve
 

BCX

Administrator
Moderator
Location
SA
First Name
Bill
Drive
2000 Galant Type-V
1997 MK Triton GLS [6G74 conversion]
2019 i30 N-Line
Good pickup, will get the read templates sorted when I get to my PC.

KSMods is a tricky one as the original ROM is a 20030013. Kenneth changed the ID at the end of the ROM, but most of the defs use the ID at the start of the rom.

I'll try and think of a better way to get the defs working for all ROMs

Workaround for now:

Basically need to edit Kenneth's rom, change the ID at 0x21a using hex editor to read something else instead of '20030013' (perhaps '20030113') which will then pick up EMKS11.xml instead when you open it.
or
Rename/edit XML files so 20030013 isn't an ID that will match (rename xml, edit and change any references in all XMLs from '20030013' to '20030113' for example)

Will post up detailed instructions soon for both of these workarounds.
 

Legnum in America

Leaving Skid Marks
Premium Member
Location
Chicago
First Name
Mike
Drive
1997 Mitsubishi Legnum VR4 COTY
2022 Subaru Outback Onyx XT
1999 Honda Civic EX
I did try EM2428 but same results, No tach and sputters. The Roms I tried are from ClubVR4 and VR-4.ru

I will double check the settings again. If still not working, I shall wait for the Roms to be uploadedon ozvr4. Also trying to get a hold of Steve from TME but no reply via email. I figure its busier down there since its summer for you.Tried it again this weekend with four different roms and all the same results? Either the ROMs are all bad or this box has got issues. Does anybody happen to have a working rom for
.Tried it again this weekend with four different roms and all the same results? Either the ROMs are all bad or this box has got issues. Does anybody happen to have a working rom for a model with automatic TCL AYC? plastic box MD362895 7202chip
 

wintertidenz

Leaving Skid Marks
Lifetime Member
Location
New Zealand
First Name
Daniel
Drive
98 Galant VR4
.Tried it again this weekend with four different roms and all the same results? Either the ROMs are all bad or this box has got issues. Does anybody happen to have a working rom for a model with automatic TCL AYC? plastic box MD362895 7202chip
Just replace the ECU. It sounds like it's an issue with the ECU itself.
 

wintertidenz

Leaving Skid Marks
Lifetime Member
Location
New Zealand
First Name
Daniel
Drive
98 Galant VR4
Good pickup, will get the read templates sorted when I get to my PC.

KSMods is a tricky one as the original ROM is a 20030013. Kenneth changed the ID at the end of the ROM, but most of the defs use the ID at the start of the rom.

I'll try and think of a better way to get the defs working for all ROMs

Workaround for now:

Basically need to edit Kenneth's rom, change the ID at 0x21a using hex editor to read something else instead of '20030013' (perhaps '20030113') which will then pick up EMKS11.xml instead when you open it.
or
Rename/edit XML files so 20030013 isn't an ID that will match (rename xml, edit and change any references in all XMLs from '20030013' to '20030113' for example)

Will post up detailed instructions soon for both of these workarounds.
I've been having a play around with this as well, I edited the ROM XML file to include the EMKS11 XML when loading - however I just don't know if that also makes it refer to the extended fuel/ignition maps.

I suspect that there might be a change in the ROM itself that Kenneth's done to point it to the right tables? (haven't had time to look into it yet)
If so, I'm guessing that this might be easy enough to add in as a option to change where it looks for each table?
 

wintertidenz

Leaving Skid Marks
Lifetime Member
Location
New Zealand
First Name
Daniel
Drive
98 Galant VR4
I am trying to do that as well, not easy finding one in the US.
I have a plastic case ECU here at home that's missing the brackets, if you can transfer them from yours then you'll be sorted.
I was using it for a test in my car but have no need for it.

Flick me a message and we can work out a price and freight.
 
Top Bottom