Stumped! Car won't shift! Urgent help needed!

DaBo$$

Hesitantly Boosting
Location
USA
First Name
Matt
Drive
Eighth Gen Galant VR4
The auto trans oil level can only be done when hot and running in neutral. Cold or off is incorrect. Ensure the car is flat, apply the handbrake leave.in Neutral, any other way is incorrect.
Ok will do!!!!!!
 

Baba Galant

Leaving Skid Marks
Lifetime Member
Location
Melbourne
First Name
John
Drive
Galant VR4 twin turbo 1997
Hey Boss, any updates? Quick question are you running an aftermarket transmission oil cooler?
 

DaBo$$

Hesitantly Boosting
Location
USA
First Name
Matt
Drive
Eighth Gen Galant VR4
Hey Boss, any updates? Quick question are you running an aftermarket transmission oil cooler?
No, no updates. Late long shifts!!!πŸ˜”πŸ˜”πŸ˜”
No aftermarket cooler. Will get to it by this weekend, hoping before, but I have to travel so more than likely by weekend.
 

DaBo$$

Hesitantly Boosting
Location
USA
First Name
Matt
Drive
Eighth Gen Galant VR4
Update!!!!!!!!
Used workshop manual and emptied the transmission as best I could. Replaced fluid with new transmission fluid and filled to capacity as per workshop manual.

Car still doesn't shift right in drive πŸ˜”πŸ˜”πŸ˜”, if holding 3000 rpm in third the transmission bounces between 2nd and 3rd, if I increase to 4000rpm and it shifts to 4th gear it has like a high stall and takes long to shift.
Also the same thing in lower gears, car takes long to shift out of them when giving about 40 percent throttle.
In tiptronic it drives and shifts fine, just in drive it doesn't shift right.

Also the manual stated that their should be about 8.5 liters total on the transmission. I emptied at by removing cooler line from radiator and starting car until the oil wasn't pouring out anymore, then stop car and remove drain plug on the side of the transmission.
After that I filled to cold line started car selected all the gears and ended in neutral for about a minute. Checked level again and repeat until level was at cold.
Took the car for a drive, it still was not shifting right and checked level at warm. It was low on the dipstick so I added about a little less than a liter and level appeared to be fine.
Was dark and had to rest up for work, so decided to stop there and let the drive to work be the test in the a.m.
Car still was not shifting right so ended up having to drive to work in tiptronic mode and when reached checked the oil level and it was above the h
ot mark all the way to the top of the dipstick where the plastic part meets metal πŸ€¦πŸΏβ€β™‚οΈ.
I followed the manual to the tee and it still seems to be overfilled.
So is my transmission finished????? 😭😭😭😭😭
 

Baba Galant

Leaving Skid Marks
Lifetime Member
Location
Melbourne
First Name
John
Drive
Galant VR4 twin turbo 1997
Quick question mate, have you changed the trans oil filter?
This is starting to sound like a shift cable or connector problem, any chance while doing the CV joint you've bumped or knocked something?
I don't want to think the auto is gone, hoping it's something simple
 

DaBo$$

Hesitantly Boosting
Location
USA
First Name
Matt
Drive
Eighth Gen Galant VR4
Quick question mate, have you changed the trans oil filter?
This is starting to sound like a shift cable or connector problem, any chance while doing the CV joint you've bumped or knocked something?
I don't want to think the auto is gone, hoping it's something simple
Yes transmission filter was changed.
It could be a possibility of knocking something when attempted to change cv.
What could I have unplugged or snag that what cause these symptoms?
Truth be told it started happening after putting the left cv back in, was the wrong cv joint so had to put back in the old in order to drive and the needle bearings in the old are gone.
The cv did snap in when put back in, there wasn't anything unplugged and we put all lines and parts back the same way.
Stumped at the moment. Any suggestion of where to start looking for something that may have need unplugged is welcome.
 
Top Bottom